CVE-2019-10216

NameCVE-2019-10216
DescriptionIn ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1880-1, DSA-4499-1
NVD severitymedium
Debian Bugs934638

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)stretch9.26a~dfsg-0+deb9u6fixed
stretch (security)9.26a~dfsg-0+deb9u7fixed
buster, buster (security)9.27~dfsg-2+deb10u4fixed
bullseye9.52.1~dfsg-1fixed
sid9.53.3~dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsourcejessie9.26a~dfsg-0+deb8u4DLA-1880-1
ghostscriptsourcestretch9.26a~dfsg-0+deb9u4DSA-4499-1
ghostscriptsourcebuster9.27~dfsg-2+deb10u1DSA-4499-1
ghostscriptsource(unstable)9.27~dfsg-3.1934638

Notes

https://www.openwall.com/lists/oss-security/2019/08/12/4
https://bugs.ghostscript.com/show_bug.cgi?id=701394
https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=5b85ddd19

Search for package or bug name: Reporting problems