CVE-2019-10744

NameCVE-2019-10744
DescriptionVersions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs933079

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-lodash (PTS)jessie2.4.1+dfsg-3vulnerable
stretch4.16.6+dfsg-2vulnerable
buster4.17.11+dfsg-2vulnerable
bullseye4.17.11+dfsg-4vulnerable
sid4.17.15+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-lodashsource(unstable)4.17.15+dfsg-1high933079

Notes

[buster] - node-lodash <no-dsa> (Minor issue; can be fixed in point release)
[stretch] - node-lodash <ignored> (Nodejs in stretch not covered by security support)
[jessie] - node-lodash <ignored> (Nodejs in stretch not covered by security support)
https://snyk.io/vuln/SNYK-JS-LODASH-450202
https://github.com/lodash/lodash/issues/4348
https://github.com/lodash/lodash/pull/4336

Search for package or bug name: Reporting problems