CVE-2019-10768

NameCVE-2019-10768
DescriptionIn AngularJS before 1.7.9 the function `merge()` could be tricked into adding or modifying properties of `Object.prototype` using a `__proto__` payload.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs945249

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
angular.js (PTS)jessie1.2.26-1fixed
jessie (security)1.2.26-1+deb8u1fixed
buster, stretch1.5.10-1vulnerable
bullseye, sid1.7.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
angular.jssource(unstable)1.7.9-1945249
angular.jssourcejessie(not affected)

Notes

[buster] - angular.js <no-dsa> (Minor issue; can be fixed via point release)
[stretch] - angular.js <ignored> (Nodejs in stretch not covered by security support)
[jessie] - angular.js <not-affected> (vulnerable code is not present, deep merging introduced later)
https://github.com/angular/angular.js/commit/add78e62004e80bb1e16ab2dfe224afa8e513bc3
https://snyk.io/vuln/SNYK-JS-ANGULAR-534884

Search for package or bug name: Reporting problems