CVE-2019-10773

NameCVE-2019-10773
DescriptionIn Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using specially crafted "bin" keys. Existing files could be overwritten depending on the current user permission set.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-yarnpkg (PTS)buster1.13.0-1+deb10u1vulnerable
bullseye, sid1.22.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-yarnpkgsource(unstable)1.21.1-1

Notes

https://github.com/yarnpkg/yarn/issues/7761#issuecomment-565493023
https://blog.daniel-ruf.de/critical-design-flaw-npm-pnpm-yarn/
https://github.com/yarnpkg/yarn/commit/039bafd74b7b1a88a53a54f8fa6fa872615e90e7
https://snyk.io/vuln/SNYK-JS-YARN-537806

Search for package or bug name: Reporting problems