CVE-2019-10784

NameCVE-2019-10784
Descriptionphppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs953945

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phppgadmin (PTS)buster5.1+ds-4vulnerable
buster (security)5.1+ds-4+deb10u1vulnerable
bookworm, bullseye7.13.0+dfsg-2vulnerable
sid7.13.0+dfsg-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phppgadminsource(unstable)(unfixed)953945

Notes

[bookworm] - phppgadmin <no-dsa> (Minor issue)
[bullseye] - phppgadmin <no-dsa> (Minor issue)
[buster] - phppgadmin <no-dsa> (Minor issue)
[stretch] - phppgadmin <no-dsa> (Minor issue)
[jessie] - phppgadmin <no-dsa> (Minor issue)
https://snyk.io/vuln/SNYK-PHP-PHPPGADMINPHPPGADMIN-543885
https://github.com/phppgadmin/phppgadmin/issues/94

Search for package or bug name: Reporting problems