CVE-2019-10901

NameCVE-2019-10901
DescriptionIn Wireshark 2.4.0 to 2.4.13, 2.6.0 to 2.6.7, and 3.0.0, the LDSS dissector could crash. This was addressed in epan/dissectors/packet-ldss.c by handling file digests properly.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1802-1, DLA-2423-1
NVD severitymedium
Debian Bugs926718

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch2.6.7-1~deb9u1vulnerable
stretch (security)2.6.20-0+deb9u1fixed
buster2.6.20-0+deb10u1fixed
bullseye, sid3.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u19DLA-1802-1
wiresharksourcestretch2.6.8-1.1~deb9u1DLA-2423-1
wiresharksource(unstable)2.6.8-1low926718

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=15620
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=cf801a25074f76dc3ae62d8ec53ace75f56ce2cd
https://www.wireshark.org/security/wnpa-sec-2019-17.html

Search for package or bug name: Reporting problems