CVE-2019-11065

NameCVE-2019-11065
DescriptionGradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs926923

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gradle (PTS)jessie1.5-2vulnerable
stretch3.2.1-1vulnerable
buster4.4.1-6vulnerable
bullseye, sid4.4.1-8vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gradlesource(unstable)(unfixed)926923

Notes

[buster] - gradle <no-dsa> (Minor issue)
[stretch] - gradle <no-dsa> (Minor issue)
[jessie] - gradle <no-dsa> (Minor issue)
https://github.com/gradle/gradle/pull/8927
https://lists.debian.org/debian-lts/2019/05/msg00021.html

Search for package or bug name: Reporting problems