CVE-2019-11068

NameCVE-2019-11068
Descriptionlibxslt through 1.1.33 allows bypass of a protection mechanism because callers of xsltCheckRead and xsltCheckWrite permit access even upon receiving a -1 error code. xsltCheckRead can return -1 for a crafted URL that is not actually invalid and is subsequently loaded.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1756-1
NVD severityhigh (attack range: remote)
Debian Bugs926895

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxslt (PTS)jessie1.1.28-2+deb8u3vulnerable
jessie (security)1.1.28-2+deb8u4fixed
stretch1.1.29-2.1vulnerable
buster, sid1.1.32-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxsltsource(unstable)(unfixed)high926895
libxsltsourcejessie1.1.28-2+deb8u4highDLA-1756-1

Notes

[stretch] - libxslt <no-dsa> (Minor issue)
https://gitlab.gnome.org/GNOME/libxslt/issues/12 (not public)
https://gitlab.gnome.org/GNOME/libxslt/commit/e03553605b45c88f0b4b2980adfbbb8f6fca2fd6

Search for package or bug name: Reporting problems