CVE-2019-11071

NameCVE-2019-11071
DescriptionSPIP 3.1 before 3.1.10 and 3.2 before 3.2.4 allows authenticated visitors to execute arbitrary code on the host server because var_memotri is mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4429-1
NVD severitymedium (attack range: remote)
Debian Bugs926764

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)jessie (security), jessie3.0.17-2+deb8u4fixed
stretch (security), stretch3.1.4-4~deb9u2fixed
buster3.2.4-1fixed
bullseye, sid3.2.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsource(unstable)3.2.4-1medium926764
spipsourcejessie(not affected)
spipsourcestretch3.1.4-4~deb9u2mediumDSA-4429-1

Notes

[jessie] - spip <not-affected> (SPIP 3.0 and earlier are not affected)
https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-Sortie-de-SPIP-3-1-10-et-SPIP-3-2-4.html
https://github.com/spip/SPIP/commit/3ef87c525bc0768c926646f999a54222b37b5d36
https://github.com/spip/SPIP/commit/824d17f424bf77d17af89c18c3dc807a3199567e

Search for package or bug name: Reporting problems