CVE-2019-11234

NameCVE-2019-11234
DescriptionFreeRADIUS before 3.0.19 does not prevent use of reflection for authentication spoofing, aka a "Dragonblood" issue, a similar issue to CVE-2019-9497.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs926958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)jessie (security), jessie2.2.5+dfsg-0.2+deb8u1fixed
stretch (security), stretch3.0.12+dfsg-5+deb9u1vulnerable
bullseye, sid, buster3.0.17+dfsg-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)3.0.17+dfsg-1.1high926958
freeradiussourcejessie(not affected)

Notes

[stretch] - freeradius <no-dsa> (Minor issue; plugin not enabled by default)
[jessie] - freeradius <not-affected> (EAP-PWD only introduced in 3.0.0)
https://github.com/FreeRADIUS/freeradius-server/commit/85497b5ff37ccb656895b826b88585898c209586
https://github.com/FreeRADIUS/freeradius-server/commit/ab4c767099f263a7cd4109bcdca80ee74210a769

Search for package or bug name: Reporting problems