CVE-2019-11371

NameCVE-2019-11371
DescriptionBWA (aka Burrow-Wheeler Aligner) 0.7.17 r1198 has a Buffer Overflow via a long prefix that is mishandled in bns_fasta2bntseq and bns_dump at btnseq.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bwa (PTS)jessie0.7.10-1vulnerable
stretch0.7.15-2+deb9u1vulnerable
buster, bullseye, sid0.7.17-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bwasource(unstable)(unfixed)unimportant

Notes

https://github.com/lh3/bwa/issues/239
Neutralised by toolchain hardening

Search for package or bug name: Reporting problems