CVE-2019-11387

NameCVE-2019-11387
DescriptionAn issue was discovered in OWASP ModSecurity Core Rule Set (CRS) through 3.1.0. /rules/REQUEST-942-APPLICATION-ATTACK-SQLI.conf allows remote attackers to cause a denial of service (ReDOS) by entering a specially crafted string with nested repetition operators.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs928053

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
modsecurity-crs (PTS)jessie2.2.9-1+deb8u1vulnerable
stretch3.0.0-3vulnerable
buster, sid3.1.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
modsecurity-crssource(unstable)(unfixed)unimportant928053

Notes

https://github.com/SpiderLabs/owasp-modsecurity-crs/issues/1359
Negligible security impact, doesn't affect the CRS rule set as used
by libapache2-mod-security2, only affects libmodsecurity3 in non-standard settings

Search for package or bug name: Reporting problems