CVE-2019-11458

NameCVE-2019-11458
DescriptionAn issue was discovered in SmtpTransport in CakePHP 3.7.6. An unserialized object with modified internal properties can trigger arbitrary file overwriting upon destruction.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cakephp (PTS)stretch2.8.5-1fixed
buster2.10.11-2fixed
bullseye, sid2.10.11-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cakephpsource(unstable)(not affected)

Notes

- cakephp <not-affected> (Vulnerable code introduced in 3.0.0)
https://github.com/cakephp/cakephp/commit/1a74e798309192a9895c9cedabd714ceee345f4e
https://github.com/cakephp/cakephp/pull/13153

Search for package or bug name: Reporting problems