CVE-2019-11505

NameCVE-2019-11505
DescriptionIn GraphicsMagick from version 1.3.8 to 1.4 snapshot-20190403 Q8, there is a heap-based buffer overflow in the function WritePDBImage of coders/pdb.c, which allows an attacker to cause a denial of service or possibly have unspecified other impact via a crafted image file. This is related to MagickBitStreamMSBWrite in magick/bit_stream.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1795-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u7fixed
stretch (security), stretch1.3.30+hg15796-1~deb9u2vulnerable
buster1.4~hg15978-1fixed
bullseye, sid1.4+really1.3.33-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.4~hg15968-1medium
graphicsmagicksourcejessie1.3.20-3+deb8u7mediumDLA-1795-1

Notes

http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/85f5bdcd246a
https://sourceforge.net/p/graphicsmagick/bugs/605/

Search for package or bug name: Reporting problems