CVE-2019-11579

NameCVE-2019-11579
Descriptiondhcp.c in dhcpcd before 7.2.1 contains a 1-byte read overflow with DHO_OPTSOVERLOADED.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1793-1
NVD severitymedium
Debian Bugs928104

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dhcpcd5 (PTS)stretch6.10.1-1vulnerable
bullseye, sid, buster7.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dhcpcd5sourcejessie6.0.5-2+deb8u1DLA-1793-1
dhcpcd5source(unstable)7.1.0-2low928104

Notes

[stretch] - dhcpcd5 <no-dsa> (Minor issue)
https://roy.marples.name/git/dhcpcd.git/commit/?id=4b67f6f1038fd4ad5ca7734eaaeba1b2ec4816b8

Search for package or bug name: Reporting problems