CVE-2019-11627

NameCVE-2019-11627
Descriptiongpg-key2ps in signing-party 1.1.x and 2.x before 2.10-1 contains an unsafe shell call enabling shell injection via a User ID.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1773-1
NVD severityhigh (attack range: remote)
Debian Bugs928256

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
signing-party (PTS)jessie1.1.10-3vulnerable
jessie (security)1.1.10-3+deb8u1fixed
stretch2.5-1vulnerable
bullseye, sid, buster2.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
signing-partysource(unstable)2.10-1high928256
signing-partysourcejessie1.1.10-3+deb8u1highDLA-1773-1

Notes

[stretch] - signing-party <no-dsa> (Will be fixed via point release)
https://salsa.debian.org/signing-party-team/signing-party/commit/cd69b6c0426a6160ef3de03fce9c7f112166d5a8

Search for package or bug name: Reporting problems