CVE-2019-11692

NameCVE-2019-11692
DescriptionA use-after-free vulnerability can occur when listeners are removed from the event listener manager while still in use, resulting in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.7, Firefox < 67, and Firefox ESR < 60.7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1800-1, DLA-1806-1, DSA-4448-1, DSA-4451-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid82.0.2-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)78.4.0esr-1~deb9u1fixed
buster68.12.0esr-1~deb10u1fixed
buster (security)78.4.0esr-1~deb10u2fixed
bullseye78.3.0esr-2fixed
sid78.4.0esr-2fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:78.4.0-1~deb9u1fixed
buster1:68.12.0-1~deb10u1fixed
buster (security)1:78.4.0-1~deb10u1fixed
bullseye1:68.12.0-1fixed
sid1:78.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsourceexperimental67.0-1
firefoxsource(unstable)67.0-2
firefox-esrsourcejessie60.7.0esr-1~deb8u1DLA-1800-1
firefox-esrsourcestretch60.7.0esr-1~deb9u1DSA-4448-1
firefox-esrsource(unstable)60.7.0esr-1
thunderbirdsourcejessie1:60.7.0-1~deb8u1DLA-1806-1
thunderbirdsourcestretch1:60.7.0-1~deb9u1DSA-4451-1
thunderbirdsource(unstable)1:60.7.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2019-13/#CVE-2019-11692
https://www.mozilla.org/en-US/security/advisories/mfsa2019-14/#CVE-2019-11692
https://www.mozilla.org/en-US/security/advisories/mfsa2019-15/#CVE-2019-11692

Search for package or bug name: Reporting problems