CVE-2019-11719

NameCVE-2019-11719
DescriptionWhen importing a curve25519 private key in PKCS#8format with leading 0x00 bytes, it is possible to trigger an out-of-bounds read in the Network Security Services (NSS) library. This could lead to information disclosure. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1857-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid78.0.1-1fixed
firefox-esr (PTS)stretch68.4.1esr-1~deb9u1fixed
stretch (security)68.10.0esr-1~deb9u1fixed
buster68.7.0esr-1~deb10u1fixed
buster (security)68.10.0esr-1~deb10u1fixed
bullseye, sid68.10.0esr-1fixed
nss (PTS)stretch (security), stretch2:3.26.2-1.1+deb9u1vulnerable
buster, buster (security)2:3.42.1-1+deb10u2fixed
bullseye, sid2:3.53.1-1fixed
thunderbird (PTS)stretch1:68.4.1-1~deb9u1fixed
stretch (security)1:68.10.0-1~deb9u1fixed
buster1:68.7.0-1~deb10u1fixed
buster (security)1:68.10.0-1~deb10u1fixed
bullseye, sid1:68.10.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)68.0-1unimportant
firefox-esrsource(unstable)60.8.0esr-1unimportant
firefox-esrsourcebuster60.8.0esr-1~deb10u1
firefox-esrsourcestretch60.8.0esr-1~deb9u1
nsssource(unstable)2:3.45-1
nsssourcebuster2:3.42.1-1+deb10u1
nsssourcejessie2:3.26-1+debu8u5DLA-1857-1
thunderbirdsource(unstable)1:60.8.0-1unimportant
thunderbirdsourcebuster1:60.8.0-1~deb10u1
thunderbirdsourcestretch1:60.8.0-1~deb9u1

Notes

[stretch] - nss <no-dsa> (Minor issue)
https://www.mozilla.org/en-US/security/advisories/mfsa2019-21/#CVE-2019-11719
https://www.mozilla.org/en-US/security/advisories/mfsa2019-22/#CVE-2019-11719
https://www.mozilla.org/en-US/security/advisories/mfsa2019-23/#CVE-2019-11719
https://hg.mozilla.org/projects/nss/rev/6cfb54d262d030783137aa6478b45ecb3cbfc624
firefox-esr in older suites than buster use the embedded copy and thus issue
is just fixed by updating firefox-esr to 60.8.0. For the others an update to
src:nss is needed as firefox-esr uses the system library.

Search for package or bug name: Reporting problems