CVE-2019-11757

NameCVE-2019-11757
DescriptionWhen following the value's prototype chain, it was possible to retain a reference to a locale, delete it, and subsequently reference it. This resulted in a use-after-free and a potentially exploitable crash. This vulnerability affects Firefox < 70, Thunderbird < 68.2, and Firefox ESR < 68.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1987-1, DLA-1997-1, DSA-4549-1, DSA-4571-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid105.0-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)91.13.0esr-1~deb10u1fixed
bullseye91.13.0esr-1~deb11u1fixed
bullseye (security)102.3.0esr-1~deb11u1fixed
bookworm102.2.0esr-1fixed
sid102.3.0esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:91.13.0-1~deb10u1fixed
bullseye (security), bullseye1:91.13.0-1~deb11u1fixed
bookworm1:102.2.2-1fixed
sid1:102.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)70.0-1
firefox-esrsourcejessie68.2.0esr-1~deb8u1DLA-1987-1
firefox-esrsourcestretch68.2.0esr-1~deb9u2DSA-4549-1
firefox-esrsourcebuster68.2.0esr-1~deb10u1DSA-4549-1
firefox-esrsource(unstable)68.2.0esr-1
thunderbirdsourcejessie1:68.2.2-1~deb8u1DLA-1997-1
thunderbirdsourcestretch1:68.2.2-1~deb9u1DSA-4571-1
thunderbirdsourcebuster1:68.2.2-1~deb10u1DSA-4571-1
thunderbirdsource(unstable)1:68.2.1-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2019-33/#CVE-2019-11757
https://www.mozilla.org/en-US/security/advisories/mfsa2019-34/#CVE-2019-11757
https://www.mozilla.org/en-US/security/advisories/mfsa2019-35/#CVE-2019-11757

Search for package or bug name: Reporting problems