CVE-2019-11762

NameCVE-2019-11762
DescriptionIf two same-origin documents set document.domain differently to become cross-origin, it was possible for them to call arbitrary DOM methods/getters/setters on the now-cross-origin window. This vulnerability affects Firefox < 70, Thunderbird < 68.2, and Firefox ESR < 68.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1987-1, DLA-1997-1, DSA-4549-1, DSA-4571-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid78.0.2-1fixed
firefox-esr (PTS)stretch68.4.1esr-1~deb9u1fixed
stretch (security)68.10.0esr-1~deb9u1fixed
buster68.7.0esr-1~deb10u1fixed
buster (security)68.10.0esr-1~deb10u1fixed
bullseye, sid68.10.0esr-1fixed
thunderbird (PTS)stretch1:68.4.1-1~deb9u1fixed
stretch (security)1:68.10.0-1~deb9u1fixed
buster1:68.7.0-1~deb10u1fixed
buster (security)1:68.10.0-1~deb10u1fixed
bullseye, sid1:68.10.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)70.0-1
firefox-esrsource(unstable)68.2.0esr-1
firefox-esrsourcebuster68.2.0esr-1~deb10u1DSA-4549-1
firefox-esrsourcejessie68.2.0esr-1~deb8u1DLA-1987-1
firefox-esrsourcestretch68.2.0esr-1~deb9u2DSA-4549-1
thunderbirdsource(unstable)1:68.2.1-1
thunderbirdsourcebuster1:68.2.2-1~deb10u1DSA-4571-1
thunderbirdsourcejessie1:68.2.2-1~deb8u1DLA-1997-1
thunderbirdsourcestretch1:68.2.2-1~deb9u1DSA-4571-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2019-33/#CVE-2019-11762
https://www.mozilla.org/en-US/security/advisories/mfsa2019-34/#CVE-2019-11762
https://www.mozilla.org/en-US/security/advisories/mfsa2019-35/#CVE-2019-11762

Search for package or bug name: Reporting problems