CVE-2019-11768

NameCVE-2019-11768
DescriptionAn issue was discovered in phpMyAdmin before 4.9.0.1. A vulnerability was reported where a specially crafted database name can be used to trigger an SQL injection attack through the designer feature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs930048

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)jessie4:4.2.12-2+deb8u2fixed
jessie (security)4:4.2.12-2+deb8u6fixed
stretch4:4.6.6-4vulnerable
sid4:4.6.6-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)(unfixed)high930048
phpmyadminsourcejessie(not affected)

Notes

[jessie] - phpmyadmin <not-affected> (vulnerable code is not present)
https://www.phpmyadmin.net/security/PMASA-2019-3/
https://github.com/phpmyadmin/phpmyadmin/commit/c1ecafc38319e8f768c9259d4d580e42acd5ee86
Code in earlier versions in js/pmd/move.js.

Search for package or bug name: Reporting problems