CVE-2019-11778

NameCVE-2019-11778
DescriptionIf an MQTT v5 client connects to Eclipse Mosquitto versions 1.6.0 to 1.6.4 inclusive, sets a last will and testament, sets a will delay interval, sets a session expiry interval, and the will delay interval is set longer than the session expiry interval, then a use after free error occurs, which has the potential to cause a crash in some situations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mosquitto (PTS)jessie1.3.4-2+deb8u1vulnerable
jessie (security)1.3.4-2+deb8u3vulnerable
stretch (security), stretch1.4.10-3+deb9u4vulnerable
buster1.5.7-1vulnerable
bullseye, sid1.6.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mosquittosource(unstable)1.6.6-1medium

Notes

https://bugs.eclipse.org/bugs/show_bug.cgi?id=551162

Search for package or bug name: Reporting problems