CVE-2019-11835

NameCVE-2019-11835
DescriptioncJSON before 1.7.11 allows out-of-bounds access, related to multiline comments.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs928726

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cjson (PTS)bullseye1.7.14-1fixed
bookworm1.7.15-1+deb12u1fixed
sid, trixie1.7.18-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cjsonsource(unstable)1.7.10-1.1928726

Notes

https://github.com/DaveGamble/cJSON/issues/338

Search for package or bug name: Reporting problems