CVE-2019-12105

NameCVE-2019-12105
DescriptionIn supervisord in Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. WARNING: This issue will not be fixed by the maintainer. The ability to run an open server will not be removed because users often use it for local development, therefore no action will be taken.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
supervisor (PTS)jessie (security), jessie3.0r1-1+deb8u1vulnerable
stretch (security), stretch3.3.1-1+deb9u1vulnerable
buster3.3.5-1vulnerable
bullseye, sid4.0.4-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
supervisorsource(unstable)(unfixed)unimportant

Notes

https://github.com/Supervisor/supervisor/issues/1245
Disupted upstream to be vulnerability. inet_http_server is not enabled by
default (neither upstream nor in Debian packaging). Details in the upstream
issue.

Search for package or bug name: Reporting problems