CVE-2019-12106

NameCVE-2019-12106
DescriptionThe updateDevice function in minissdpd.c in MiniUPnP MiniSSDPd 1.4 and 1.5 allows a remote attacker to crash the process due to a Use After Free vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1805-1
NVD severitymedium (attack range: remote)
Debian Bugs929297

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
minissdpd (PTS)jessie1.2.20130907-3+deb8u1vulnerable
jessie (security)1.2.20130907-3+deb8u2fixed
stretch1.2.20130907-4.1vulnerable
bullseye, sid, buster1.5.20190210-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
minissdpdsource(unstable)1.5.20190210-1medium929297
minissdpdsourcejessie1.2.20130907-3+deb8u2mediumDLA-1805-1

Notes

[stretch] - minissdpd <no-dsa> (Minor issue)
https://github.com/miniupnp/miniupnp/commit/cd506a67e174a45c6a202eff182a712955ed6d6f

Search for package or bug name: Reporting problems