CVE-2019-12107

NameCVE-2019-12107
DescriptionThe upnp_event_prepare function in upnpevents.c in MiniUPnP MiniUPnPd through 2.1 allows a remote attacker to leak information from the heap due to improper validation of an snprintf return value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1811-1
NVD severitymedium (attack range: remote)
Debian Bugs930050

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
miniupnpd (PTS)jessie1.8.20140523-4vulnerable
jessie (security)1.8.20140523-4+deb8u1fixed
stretch1.8.20140523-4.1+deb9u1vulnerable
bullseye, sid, buster2.1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
miniupnpdsource(unstable)2.1-6medium930050
miniupnpdsourcejessie1.8.20140523-4+deb8u1mediumDLA-1811-1

Notes

[stretch] - miniupnpd <no-dsa> (Minor issue)
https://github.com/miniupnp/miniupnp/commit/bec6ccec63cadc95655721bc0e1dd49dac759d94
check, might affect minidlna

Search for package or bug name: Reporting problems