CVE-2019-12111

NameCVE-2019-12111
DescriptionA Denial Of Service vulnerability in MiniUPnP MiniUPnPd through 2.1 exists due to a NULL pointer dereference in copyIPv6IfDifferent in pcpserver.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1811-1
NVD severitymedium (attack range: remote)
Debian Bugs930050

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
miniupnpd (PTS)jessie1.8.20140523-4vulnerable
jessie (security)1.8.20140523-4+deb8u1fixed
stretch1.8.20140523-4.1+deb9u1fixed
buster, sid2.1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
miniupnpdsource(unstable)2.1-6medium930050
miniupnpdsourcejessie1.8.20140523-4+deb8u1mediumDLA-1811-1
miniupnpdsourcestretch(not affected)

Notes

[stretch] - miniupnpd <not-affected> (Vulnerable code introduced later)
https://github.com/miniupnp/miniupnp/commit/cb8a02af7a5677cf608e86d57ab04241cf34e24f

Search for package or bug name: Reporting problems