CVE-2019-12155

NameCVE-2019-12155
Descriptioninterface_release_resource in hw/display/qxl.c in QEMU 4.0.0 has a NULL pointer dereference.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4454-1
NVD severitymedium (attack range: remote)
Debian Bugs929353

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u11vulnerable
stretch1:2.8+dfsg-6+deb9u5vulnerable
stretch (security)1:2.8+dfsg-6+deb9u8fixed
buster1:3.1+dfsg-8~deb10u1fixed
bullseye, sid1:3.1+dfsg-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:3.1+dfsg-8medium929353
qemusourcebuster1:3.1+dfsg-8~deb10u1medium
qemusourcestretch1:2.8+dfsg-6+deb9u6mediumDSA-4454-1
qemu-kvmsource(unstable)(unfixed)medium

Notes

https://www.openwall.com/lists/oss-security/2019/05/22/1
https://git.qemu.org/?p=qemu.git;a=commit;h=d52680fc932efb8a2f334cc6993e705ed1e31e99

Search for package or bug name: Reporting problems