CVE-2019-12247

NameCVE-2019-12247
Description** DISPUTED ** QEMU 3.0.0 has an Integer Overflow because the qga/commands*.c files do not check the length of the argument list or the number of environment variables. NOTE: This has been disputed as not exploitable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs929365

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u11vulnerable
stretch1:2.8+dfsg-6+deb9u5vulnerable
stretch (security)1:2.8+dfsg-6+deb9u7vulnerable
buster1:3.1+dfsg-8~deb10u1vulnerable
sid1:3.1+dfsg-8vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)unimportant929365
qemu-kvmsource(unstable)(unfixed)unimportant

Notes

https://lists.gnu.org/archive/html/qemu-devel/2019-05/msg04596.html
https://lists.gnu.org/archive/html/qemu-devel/2019-05/msg05457.html
Disputed upstream as not beeing exploitable.

Search for package or bug name: Reporting problems