CVE-2019-12383

NameCVE-2019-12383
DescriptionTor Browser before 8.0.1 has an information exposure vulnerability. It allows remote attackers to detect the browser's UI locale by measuring a button width, even if the user has a "Don't send my language" setting.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid70.0.1-1vulnerable
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1vulnerable
jessie (security)68.2.0esr-1~deb8u1vulnerable
stretch60.7.1esr-1~deb9u1vulnerable
stretch (security)68.2.0esr-1~deb9u2vulnerable
buster60.8.0esr-1~deb10u1vulnerable
buster (security)68.2.0esr-1~deb10u1vulnerable
bullseye, sid68.2.0esr-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)(unfixed)unimportant
firefox-esrsource(unstable)(unfixed)unimportant

Notes

https://gitweb.torproject.org/tor-browser.git/commit/?id=cbb04b72c68272c2de42f157d40cd7d29a6b7b55
https://hackerone.com/reports/282748
https://trac.torproject.org/projects/tor/ticket/24056
This affects Firefox, but it's not a security issue in Firefox by itself

Search for package or bug name: Reporting problems