CVE-2019-12435

NameCVE-2019-12435
DescriptionSamba 4.9.x before 4.9.9 and 4.10.x before 4.10.5 has a NULL pointer dereference, leading to Denial of Service. This is related to the AD DC DNS management server (dnsserver) RPC server process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs930748

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch2:4.5.16+dfsg-1+deb9u2fixed
stretch (security)2:4.5.16+dfsg-1+deb9u3fixed
buster2:4.9.5+dfsg-5fixed
buster (security)2:4.9.5+dfsg-5+deb10u1fixed
bullseye2:4.13.5+dfsg-1fixed
sid2:4.13.5+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcejessie(not affected)
sambasourcestretch(not affected)
sambasource(unstable)2:4.9.5+dfsg-5930748

Notes

[stretch] - samba <not-affected> (Only affects Samba since 4.9)
[jessie] - samba <not-affected> (Only affects Samba since 4.9)
https://www.samba.org/samba/security/CVE-2019-12435.html

Search for package or bug name: Reporting problems