CVE-2019-12525

NameCVE-2019-12525
DescriptionAn issue was discovered in Squid 3.3.9 through 3.5.28 and 4.x through 4.7. When Squid is configured to use Digest authentication, it parses the header Proxy-Authorization. It searches for certain tokens such as domain, uri, and qop. Squid checks if this token's value starts with a quote and ends with one. If so, it performs a memcpy of its length minus 2. Squid never checks whether the value is just a single quote (which would satisfy its requirements), leading to a memcpy of its length minus 1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1858-1, DSA-4507-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u1fixed
bullseye4.6-1+deb10u1vulnerable
sid4.8-1fixed
squid3 (PTS)jessie3.4.8-6+deb8u5vulnerable
jessie (security)3.4.8-6+deb8u8fixed
stretch (security), stretch3.5.23-5+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.8-1high
squidsourcebuster4.6-1+deb10u1highDSA-4507-1
squid3source(unstable)(unfixed)high
squid3sourcejessie3.4.8-6+deb8u8highDLA-1858-1

Notes

http://www.squid-cache.org/Advisories/SQUID-2019_3.txt
Squid 4: http://www.squid-cache.org/Versions/v4/changesets/squid-4-409956536647b3a05ee1e367424a24ae6b8f13fd.patch
Squid 3.5: http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-ec0d0f39cf28da14eead0ba5e777e95855bc2f67.patch

Search for package or bug name: Reporting problems