CVE-2019-12594

NameCVE-2019-12594
DescriptionDOSBox 0.74-2 has Incorrect Access Control.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1845-1, DSA-4478-1
NVD severityhigh (attack range: remote)
Debian Bugs931222

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dosbox (PTS)jessie0.74-4vulnerable
jessie (security)0.74-4+deb8u1fixed
stretch0.74-4.2+deb9u1vulnerable
stretch (security)0.74-4.2+deb9u2fixed
buster0.74-2-3vulnerable
buster (security)0.74-2-3+deb10u1fixed
bullseye, sid0.74-3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dosboxsource(unstable)0.74-3-1high931222
dosboxsourcebuster0.74-2-3+deb10u1highDSA-4478-1
dosboxsourcejessie0.74-4+deb8u1highDLA-1845-1
dosboxsourcestretch0.74-4.2+deb9u2highDSA-4478-1

Notes

Fixed in 0.74-3 upstream.
https://github.com/Alexandre-Bartel/CVE-2019-12594
Upstream clarification https://sourceforge.net/p/dosbox/bugs/508/
Fixed by https://sourceforge.net/p/dosbox/code-0/4246/

Search for package or bug name: Reporting problems