CVE-2019-12625

NameCVE-2019-12625
DescriptionClamAV versions prior to 0.101.3 are susceptible to a zip bomb vulnerability where an unauthenticated attacker can cause a denial of service condition by sending crafted messages to an affected system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1953-1
NVD severitymedium
Debian Bugs934359

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)jessie0.100.0+dfsg-0+deb8u1vulnerable
jessie (security)0.101.4+dfsg-0+deb8u2fixed
stretch0.101.4+dfsg-0+deb9u1fixed
buster0.101.4+dfsg-0+deb10u1fixed
bullseye, sid0.101.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.101.4+dfsg-1934359
clamavsourcebuster0.101.4+dfsg-0+deb10u1
clamavsourcejessie0.101.4+dfsg-0+deb8u1DLA-1953-1
clamavsourcestretch0.101.4+dfsg-0+deb9u1

Notes

https://www.openwall.com/lists/oss-security/2019/08/06/3
https://bugzilla.clamav.net/show_bug.cgi?id=12356
Partially adressed already in 0.101.2+dfsg-3 but incomplete.
https://blog.clamav.net/2019/08/clamav-01014-security-patch-release-has.html

Search for package or bug name: Reporting problems