CVE-2019-12827

NameCVE-2019-12827
DescriptionBuffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs931980

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)jessie1:11.13.1~dfsg-2+deb8u5fixed
jessie (security)1:11.13.1~dfsg-2+deb8u8fixed
stretch (security), stretch1:13.14.1~dfsg-2+deb9u4vulnerable
buster1:16.2.1~dfsg-1+deb10u1fixed
bullseye, sid1:16.2.1~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:16.2.1~dfsg-2931980
asterisksourcebuster1:16.2.1~dfsg-1+deb10u1
asterisksourcejessie(not affected)

Notes

[stretch] - asterisk <no-dsa> (Minor issue)
[jessie] - asterisk <not-affected> (Vulnerable code not present)
https://downloads.asterisk.org/pub/security/AST-2019-002.html
https://issues.asterisk.org/jira/browse/ASTERISK-28447

Search for package or bug name: Reporting problems