CVE-2019-13113

NameCVE-2019-13113
DescriptionExiv2 through 0.27.1 allows an attacker to cause a denial of service (crash due to assertion failure) via an invalid data location in a CRW image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)jessie0.24-4.1vulnerable
jessie (security)0.24-4.1+deb8u4vulnerable
stretch (security), stretch0.25-3.1+deb9u1vulnerable
bullseye, sid, buster0.25-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2source(unstable)(unfixed)unimportant

Notes

https://github.com/Exiv2/exiv2/commit/6212806b7637be683a56c769a8d905153996d933
https://github.com/Exiv2/exiv2/commit/ccde30afa8ca787a3fe17388a15977f107a53b72
https://github.com/Exiv2/exiv2/issues/841
Negligible security impact

Search for package or bug name: Reporting problems