CVE-2019-13115

NameCVE-2019-13115
DescriptionIn libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1730-3
NVD severitymedium
Debian Bugs932329

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libssh2 (PTS)jessie1.4.3-4.1+deb8u1vulnerable
jessie (security)1.4.3-4.1+deb8u6fixed
stretch (security), stretch1.7.0-1+deb9u1vulnerable
bullseye, sid, buster1.8.0-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libssh2source(unstable)(unfixed)932329
libssh2sourcejessie1.4.3-4.1+deb8u4DLA-1730-3

Notes

[buster] - libssh2 <no-dsa> (Minor issue)
[stretch] - libssh2 <no-dsa> (Minor issue)
https://blog.semmle.com/libssh2-integer-overflow/
https://github.com/libssh2/libssh2/pull/350

Search for package or bug name: Reporting problems