CVE-2019-13223

NameCVE-2019-13223
DescriptionA reachable assertion in the lookup1_values function in stb_vorbis through 2019-03-04 allows an attacker to cause a denial of service by opening a crafted Ogg Vorbis file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3305-1
Debian Bugs934966

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libstb (PTS)buster0.0~git20180212.15.e6afb9c-1vulnerable
buster (security)0.0~git20180212.15.e6afb9c-1+deb10u1fixed
bullseye0.0~git20200713.b42009b+ds-1fixed
bookworm0.0~git20220908.8b5f1f3+ds-1fixed
sid, trixie0.0~git20230129.5736b15+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libstbsourcebuster0.0~git20180212.15.e6afb9c-1+deb10u1DLA-3305-1
libstbsource(unstable)0.0~git20190817.1.052dce1-1934966

Notes

https://github.com/nothings/stb/commit/98fdfc6df88b1e34a736d5e126e6c8139c8de1a6
Potentially affects liblivemedia, retroarch, godot, yquake2, pax-britannica, libxmp, faudio

Search for package or bug name: Reporting problems