CVE-2019-13307

NameCVE-2019-13307
DescriptionImageMagick 7.0.8-50 Q16 has a heap-based buffer overflow at MagickCore/statistic.c in EvaluateImages because of mishandling rows.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs931448

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12vulnerable
jessie (security)8:6.8.9.9-5+deb8u17vulnerable
stretch8:6.9.7.4+dfsg-11+deb9u6vulnerable
stretch (security)8:6.9.7.4+dfsg-11+deb9u7vulnerable
bullseye, sid, buster8:6.9.10.23+dfsg-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)(unfixed)medium931448

Notes

[jessie] - imagemagick <no-dsa> (Low tier issue, patch fairly intrusive)
https://github.com/ImageMagick/ImageMagick/issues/1615
https://github.com/ImageMagick/ImageMagick6/commit/91e58d967a92250439ede038ccfb0913a81e59fe
incomplete, introduces a memory leak, follow-up patches:
https://github.com/ImageMagick/ImageMagick6/commit/e6d26d4e2f07375ddbf46a857d309d51eeff7ee1
https://github.com/ImageMagick/ImageMagick6/commit/643921ca69a20b203faebd0b287d8b7012dc749d

Search for package or bug name: Reporting problems