CVE-2019-13345

NameCVE-2019-13345
DescriptionThe cachemgr.cgi web module of Squid through 4.7 has XSS via the user_name or auth parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1847-1, DSA-4507-1
NVD severitymedium (attack range: remote)
Debian Bugs931478

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u1fixed
bullseye4.6-1+deb10u1vulnerable
sid4.8-1fixed
squid3 (PTS)jessie3.4.8-6+deb8u5vulnerable
jessie (security)3.4.8-6+deb8u8fixed
stretch (security), stretch3.5.23-5+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.8-1medium931478
squidsourcebuster4.6-1+deb10u1mediumDSA-4507-1
squid3source(unstable)(unfixed)medium
squid3sourcejessie3.4.8-6+deb8u7mediumDLA-1847-1

Notes

http://www.squid-cache.org/Advisories/SQUID-2019_6.txt
https://bugs.squid-cache.org/show_bug.cgi?id=4957
https://github.com/squid-cache/squid/pull/429
Squid 4: http://www.squid-cache.org/Versions/v4/changesets/squid-4-be1dc8614e7514103ba84d4067ed6fd15ab8f82e.patch
Squid 3.x: http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-5730c2b5cb56e7639dc423dd62651c8736a54e35.patch

Search for package or bug name: Reporting problems