CVE-2019-13615

NameCVE-2019-13615
Descriptionlibebml before 1.3.6, as used in the MKV module in VideoLAN VLC Media Player binaries before 3.0.3, has a heap-based buffer over-read in EbmlElement::FindNextElement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs932241

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libebml (PTS)jessie (security), jessie1.3.0-2+deb8u1vulnerable
stretch1.3.4-1vulnerable
buster1.3.6-2fixed
bullseye, sid1.3.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libebmlsource(unstable)1.3.6-1low932241

Notes

[stretch] - libebml <no-dsa> (Minor issue)
[jessie] - libebml <no-dsa> (Minor issue)
https://trac.videolan.org/vlc/ticket/22474
Issue was originally reported to vlc project, but the underlying issue is
found in the libebml library
https://github.com/Matroska-Org/libebml/commit/05beb69ba60acce09f73ed491bb76f332849c3a0
https://github.com/Matroska-Org/libebml/commit/ff0dc3cc21494578ce731f5d7dcde5fdec23d40f
https://github.com/Matroska-Org/libebml/commit/b66ca475be967547af9a3784e720fbbacd381be6
https://github.com/Matroska-Org/libebml/commit/534dfdb995edc18e528de8ce9fa20b3df88426ae

Search for package or bug name: Reporting problems