CVE-2019-13618

NameCVE-2019-13618
DescriptionIn GPAC before 0.8.0, isomedia/isom_read.c in libgpac.a has a heap-based buffer over-read, as demonstrated by a crash in gf_m2ts_sync in media_tools/mpegts.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs932242

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)jessie0.5.0+svn5324~dfsg1-1vulnerable
jessie (security)0.5.0+svn5324~dfsg1-1+deb8u4vulnerable
stretch0.5.2-426-gc5ad4e4+dfsg5-3+deb9u1vulnerable
bullseye, sid, buster0.5.2-426-gc5ad4e4+dfsg5-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsource(unstable)(unfixed)low932242

Notes

[buster] - gpac <no-dsa> (Minor issue)
[stretch] - gpac <no-dsa> (Minor issue)
[jessie] - gpac <no-dsa> (Minor issue)
https://github.com/gpac/gpac/issues/1250
https://github.com/gpac/gpac/commit/c23d54ed15a70b4543e3191e6ead5097cda0878b

Search for package or bug name: Reporting problems