CVE-2019-13640

NameCVE-2019-13640
DescriptionIn qBittorrent before 4.1.7, the function Application::runExternalProgram() located in app/application.cpp allows command injection via shell metacharacters in the torrent name parameter or current tracker parameter, as demonstrated by remote command execution via a crafted name within an RSS feed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs932539

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qbittorrent (PTS)jessie3.1.10-1fixed
stretch3.3.7-3vulnerable
buster4.1.5-1vulnerable
bullseye, sid4.1.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qbittorrentsource(unstable)4.1.7-1high932539
qbittorrentsourcejessie(not affected)

Notes

[jessie] - qbittorrent <not-affected> (Vulnerable code not present in 3.1.x series)
https://github.com/qbittorrent/qBittorrent/issues/10925

Search for package or bug name: Reporting problems