CVE-2019-13917

NameCVE-2019-13917
DescriptionExim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4488-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)jessie (security), jessie4.84.2-2+deb8u5fixed
stretch4.89-2+deb9u3vulnerable
stretch (security)4.89-2+deb9u5fixed
buster4.92-8vulnerable
buster (security)4.92-8+deb10u1fixed
bullseye, sid4.92.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.92-10high
exim4sourcebuster4.92-8+deb10u1highDSA-4488-1
exim4sourcejessie(not affected)
exim4sourcestretch4.89-2+deb9u5highDSA-4488-1

Notes

[jessie] - exim4 <not-affected> (Vulnerable code confirmed as introduced in version 4.85)
https://www.openwall.com/lists/oss-security/2019/07/22/3
https://www.exim.org/static/doc/security/CVE-2019-13917.txt
https://git.exim.org/exim.git/commit/21aa05977abff1eaa69bb97ef99080220915f7c0

Search for package or bug name: Reporting problems