CVE-2019-14235

NameCVE-2019-14235
DescriptionAn issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x before 2.2.4. If passed certain inputs, django.utils.encoding.uri_to_iri could lead to significant memory usage due to a recursion when repercent-encoding invalid UTF-8 octet sequences.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4498-1
NVD severitymedium (attack range: remote)
Debian Bugs934026

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)jessie1.7.11-1+deb8u3fixed
jessie (security)1.7.11-1+deb8u7fixed
stretch (security), stretch1:1.10.7-2+deb9u6fixed
buster, buster (security)1:1.11.23-1~deb10u1fixed
bullseye1:1.11.23-1~deb10u1vulnerable
sid2:2.2.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)2:2.2.4-1medium934026
python-djangosourcebuster1:1.11.23-1~deb10u1mediumDSA-4498-1
python-djangosourcejessie(not affected)
python-djangosourcestretch1:1.10.7-2+deb9u6mediumDSA-4498-1

Notes

[jessie] - python-django <not-affected> (Vulnerable code not present)
https://www.djangoproject.com/weblog/2019/aug/01/security-releases/
https://github.com/django/django/commit/cf694e6852b0da7799f8b53f1fb2f7d20cf17534 (2.2.x)
https://github.com/django/django/commit/869b34e9b3be3a4cfcb3a145f218ffd3f5e3fd79 (1.11.x)

Search for package or bug name: Reporting problems