CVE-2019-14267

NameCVE-2019-14267
DescriptionPDFResurrect 0.15 has a buffer overflow via a crafted PDF file because data associated with startxref and %%EOF is mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdfresurrect (PTS)stretch0.12-6vulnerable
stretch (security)0.12-6+deb9u1vulnerable
buster0.15-2vulnerable
bullseye0.22-1fixed
bookworm, sid0.22-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdfresurrectsource(unstable)0.16-1unimportant

Notes

https://github.com/enferex/pdfresurrect/commit/4ea7a6f4f51d0440da651d099247e2273f811dbc
Crash in CLI tool, negligible security impact, hardening build

Search for package or bug name: Reporting problems