CVE-2019-14271

NameCVE-2019-14271
DescriptionIn Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code injection can occur when the nsswitch facility dynamically loads a library inside a chroot that contains the contents of the container.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4521-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
docker.io (PTS)buster18.09.1+dfsg1-7.1vulnerable
buster (security)18.09.1+dfsg1-7.1+deb10u1fixed
bullseye18.09.1+dfsg1-9fixed
sid18.09.9+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
docker.iosource(unstable)18.09.1+dfsg1-9high
docker.iosourcebuster18.09.1+dfsg1-7.1+deb10u1highDSA-4521-1

Notes

https://github.com/moby/moby/issues/39449
https://github.com/moby/moby/pull/39612 (19.03.x)
Fix needs to be backported to 18.09 as well:
https://github.com/docker/engine/pull/305 (18.09.x)
https://github.com/moby/moby/pull/39612#issuecomment-517999360

Search for package or bug name: Reporting problems