CVE-2019-14283

NameCVE-2019-14283
DescriptionIn the Linux kernel before 5.2.3, set_geometry in drivers/block/floppy.c does not validate the sect and head fields, as demonstrated by an integer overflow and out-of-bounds read. It can be triggered by an unprivileged local user when a floppy disk has been inserted. NOTE: QEMU creates the floppy device by default.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1884-1, DLA-1885-1, DSA-4495-1, DSA-4497-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.72-1fixed
stretch4.9.168-1vulnerable
stretch (security)4.9.168-1+deb9u5fixed
buster4.19.37-5vulnerable
buster (security)4.19.37-5+deb10u2fixed
bullseye4.19.37-6vulnerable
sid5.2.9-2fixed
linux-4.9 (PTS)jessie (security)4.9.168-1+deb9u5~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)5.2.6-1medium
linuxsourcebuster4.19.37-5+deb10u2mediumDSA-4495-1
linuxsourcejessie3.16.72-1mediumDLA-1884-1
linuxsourcestretch4.9.168-1+deb9u5mediumDSA-4497-1
linux-4.9sourcejessie4.9.168-1+deb9u5~deb8u1mediumDLA-1885-1

Notes

Fixed by: https://git.kernel.org/linus/da99466ac243f15fbba65bd261bfc75ffa1532b6

Search for package or bug name: Reporting problems