CVE-2019-14287

NameCVE-2019-14287
DescriptionIn Sudo before 1.8.28, an attacker with access to a Runas ALL sudoer account can bypass certain policy blacklists and session PAM modules, and can cause incorrect logging, by invoking sudo with a crafted user ID. For example, this allows bypass of !root configuration, and USER= logging, for a "sudo -u \#$((0xffffffff))" command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1964-1, DSA-4543-1
NVD severityhigh
Debian Bugs942322

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)jessie1.8.10p3-1+deb8u5vulnerable
jessie (security)1.8.10p3-1+deb8u6fixed
stretch1.8.19p1-2.1vulnerable
stretch (security)1.8.19p1-2.1+deb9u1fixed
buster, buster (security)1.8.27-1+deb10u1fixed
bullseye, sid1.8.29-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.8.27-1.1942322
sudosourcebuster1.8.27-1+deb10u1DSA-4543-1
sudosourcejessie1.8.10p3-1+deb8u6DLA-1964-1
sudosourcestretch1.8.19p1-2.1+deb9u1DSA-4543-1

Notes

https://www.sudo.ws/alerts/minus_1_uid.html
Patch: https://www.sudo.ws/repos/sudo/rev/83db8dba09e7
Fix test regression: https://www.sudo.ws/repos/sudo/rev/db06a8336c09
Patch: https://www.openwall.com/lists/oss-security/2019/10/15/2 (1.8.5, 1.8.10)

Search for package or bug name: Reporting problems