CVE-2019-14295

NameCVE-2019-14295
DescriptionAn Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs933232

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
upx-ucl (PTS)jessie3.91-1vulnerable
stretch3.91-4vulnerable
buster3.95-1vulnerable
bullseye, sid3.95-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
upx-uclsource(unstable)3.95-2unimportant933232

Notes

https://github.com/upx/upx/issues/286
https://github.com/upx/upx/commit/58b122d97da1e02dfec24b10b6b8f56218b5622c
https://github.com/upx/upx/commit/6a53c0b3d499d62346a5c51034db543a4ef78ea3

Search for package or bug name: Reporting problems